Redirection Issue on product page
Resolved
Mar 04 at 05:50pm CET
Post-Mortem: Nginx Redirection Issue
Incident Summary
On March 4, 2025, a redirection issue in Nginx caused some clients to be unable to access the new Respect-Code product page. Instead of being redirected, affected users encountered a 404 Page Not Found error. The issue was identified and resolved promptly.
Root Cause
The old page was not redirecting to the new one for some clients due to missing Respect-Code ID entries in the Nginx redirection file. This resulted in users encountering a 404 error page instead of being automatically redirected.
Impact
- Redirection Failure: Some clients were unable to access the updated product page.
- 404 Error: Affected users saw a 404 Page Not Found instead of being redirected.
- Affected Users: Visitors relying on the old URL to reach the new page.
Resolution
- Identified the missing Respect-Code ID entries in the Nginx redirection file.
- Updated the configuration to include the correct redirection rules.
- Restarted Nginx after verifying the redirection behavior.
Preventive Measures
- Validation Checks: Implemented automated validation checks to ensure all required redirects are present before deployment.
- Review Process: Improved internal review processes for managing Nginx redirection configurations.
- Monitoring & Alerts: Added monitoring alerts to detect failed redirections earlier.
Conclusion
The issue was resolved swiftly, and additional safeguards have been put in place to prevent recurrence.
We apologize for any inconvenience caused and appreciate your understanding.
Respect Code Team
Affected services
Created
Mar 04 at 03:00pm CET
Issue: We are currently experiencing a redirection issue affecting the Respect-Code product page. Some users are encountering a 404 Page Not Found error instead of being redirected to the new page.
Impact: Affected users are unable to access the product page via the old URL.
Status: Our team has identified the issue as a missing redirection entry in the Nginx configuration and is actively working on a fix.
Next Update: We will provide further updates once the issue is resolved.
We apologize for the inconvenience and appreciate your patience.
Respect Code Team
Affected services